Update pg gem to v1.2.2

This adds support for Ruby 2.7 and PostgreSQL 12. Omnibus is also
shipping two versions of the pg gem (v1.2.2 and v1.1.4), so let's make
this consistent.

Full list of changes:
https://github.com/ged/ruby-pg/blob/master/History.rdoc
2 jobs for sh-update-pg-gem in 2 minutes and 2 seconds (queued for 1 second)
Status Job ID Name Coverage
  Test
passed #6423771
rspec

00:02:02

passed #6423772
rubocop

00:02:00