Commit 1f199894 authored by Takuya Noguchi's avatar Takuya Noguchi

Update Docker CE to 19.03.1

Signed-off-by: default avatarTakuya Noguchi <takninnovationresearch@gmail.com>
parent e46fa3a8
......@@ -68,11 +68,11 @@ ruby-2.6.3-golang-1.11-git-2.22-chrome-73.0-node-12.x-yarn-1.16-postgresql-10-gr
ruby-2.6.3-golang-1.11-git-2.22-chrome-73.0-node-12.x-yarn-1.16-postgresql-11-graphicsmagick-1.3.33 test: *test_custom
# gitlab:assets:compile step
ruby-2.6.3-git-2.22-chrome-73.0-node-12.x-yarn-1.16-graphicsmagick-1.3.33-docker-18.06.1 test: *test_custom
ruby-2.6.3-git-2.22-chrome-73.0-node-12.x-yarn-1.16-graphicsmagick-1.3.33-docker-19.03.1 test: *test_custom
# Used by www-gitlab-com's rspec job: https://gitlab.com/gitlab-com/www-gitlab-com/blob/master/.gitlab-ci.yml
ruby-2.4.5-git-2.18-chrome-69.0-docker-18.06.1 test: *test_custom
ruby-2.6.3-git-2.21-chrome-74.0-docker-18.06.1 test: *test_custom
ruby-2.4.5-git-2.18-chrome-69.0-docker-19.03.1 test: *test_custom
ruby-2.6.3-git-2.21-chrome-74.0-docker-19.03.1 test: *test_custom
# Used by https://gitlab.com/gitlab-org/distribution/gitlab-provisioner/
ruby-2.3-ansible-2.5.1-terraform-0.11 test: *test_custom
......@@ -117,11 +117,11 @@ ruby-2.6.3-golang-1.11-git-2.22-chrome-73.0-node-12.x-yarn-1.16-postgresql-10-gr
ruby-2.6.3-golang-1.11-git-2.22-chrome-73.0-node-12.x-yarn-1.16-postgresql-11-graphicsmagick-1.3.33: *build_and_deploy_custom
# gitlab:assets:compile step
ruby-2.6.3-git-2.22-chrome-73.0-node-12.x-yarn-1.16-graphicsmagick-1.3.33-docker-18.06.1: *build_and_deploy_custom
ruby-2.6.3-git-2.22-chrome-73.0-node-12.x-yarn-1.16-graphicsmagick-1.3.33-docker-19.03.1: *build_and_deploy_custom
# Used by www-gitlab-com's rspec job: https://gitlab.com/gitlab-com/www-gitlab-com/blob/master/.gitlab-ci.yml
ruby-2.4.5-git-2.18-chrome-69.0-docker-18.06.1: *build_and_deploy_custom
ruby-2.6.3-git-2.22-chrome-74.0-docker-18.06.1: *build_and_deploy_custom
ruby-2.4.5-git-2.18-chrome-69.0-docker-19.03.1: *build_and_deploy_custom
ruby-2.6.3-git-2.22-chrome-74.0-docker-19.03.1: *build_and_deploy_custom
# Used by https://gitlab.com/gitlab-org/distribution/gitlab-provisioner/
ruby-2.3-ansible-2.5.1-terraform-0.11: *build_and_deploy_custom
......
......@@ -2,7 +2,7 @@ FROM ruby:2.4
WORKDIR /home/qa
RUN wget -q https://download.docker.com/linux/static/stable/x86_64/docker-18.06.1-ce.tgz && \
tar -zxf docker-18.06.1-ce.tgz && mv docker/docker /usr/local/bin/docker && \
echo "2d92728714d794f78619785a2c638b58b0b15e60b340de51886bf6d3730f31f0 /usr/local/bin/docker" | sha256sum -c - && \
rm docker-18.06.1-ce.tgz
RUN wget -q https://download.docker.com/linux/static/stable/x86_64/docker-19.03.1.tgz && \
tar -zxf docker-19.03.1.tgz && mv docker/docker /usr/local/bin/docker && \
echo "9b6191f64cb89e706dc29390408260d643e88f7f853d8878b2fb0360186b2ac3 /usr/local/bin/docker" | sha256sum -c - && \
rm docker-19.03.1.tgz
......@@ -21,7 +21,7 @@ apt-get update
PACKAGE_VERSION=$(apt-cache policy docker-ce | awk -v dv=${DOCKER_VERSION} '$1 ~ dv {print $1}')
apt-get install -y docker-ce=${PACKAGE_VERSION}
apt-get install -y docker-ce=${PACKAGE_VERSION} docker-ce-cli=${PACKAGE_VERSION}
apt-get -yq autoremove
apt-get clean -yqq
rm -rf /var/lib/apt/lists/*
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment