Commit 58b00341 authored by Richard Clamp's avatar Richard Clamp

Loosen the pinning on "ohai"

Ohai requirement of ~> 8.0 is incompatible with Chef 13 or newer.

Unpin the requirement a little to allow for Ohai up to 14.x, as for
omnibus's needs the Ohai API should be stable up through Chef/Omnibus 14

As we may now resolve to a dependency that requires ruby >= 2.3, also
bump Omnibus's minimum required ruby >= 2.3 in the gemspec, updates the
README to specify ruby 2.2, and drops the 2.2 testing from appveyor and
travis.
Signed-off-by: default avatarRichard Clamp <richardc@unixbeard.net>
parent 63e90811
sudo: false
rvm:
- 2.2.7
- 2.3.4
- 2.4.1
bundler_args: "--jobs 7 --without docs local"
......
......@@ -17,7 +17,7 @@ This project is managed by the CHEF Release Engineering team. For more informati
Omnibus is designed to run with a minimal set of prerequisites. You will need the following:
- Ruby 2.2+
- Ruby 2.3+
- Bundler
## Get Started
......
......@@ -8,7 +8,6 @@ environment:
matrix:
- RUBY_VERSION: 24
- RUBY_VERSION: 23
- RUBY_VERSION: 22
clone_folder: c:\projects\omnibus
clone_depth: 1
......
......@@ -13,7 +13,7 @@ Gem::Specification.new do |gem|
gem.description = gem.summary
gem.homepage = "https://github.com/chef/omnibus"
gem.required_ruby_version = ">= 2.2"
gem.required_ruby_version = ">= 2.3"
gem.files = %w{ LICENSE README.md Rakefile Gemfile } + Dir.glob("*.gemspec") + Dir.glob("{bin,lib,resources,spec}/**/*")
gem.bindir = "bin"
......@@ -26,7 +26,7 @@ Gem::Specification.new do |gem|
gem.add_dependency "cleanroom", "~> 1.0"
gem.add_dependency "ffi-yajl", "~> 2.2"
gem.add_dependency "mixlib-shellout", "~> 2.0"
gem.add_dependency "ohai", "~> 8.0"
gem.add_dependency "ohai", ">= 8.6.0.alpha.1", "< 15"
gem.add_dependency "ruby-progressbar", "~> 1.7"
gem.add_dependency "thor", "~> 0.18"
gem.add_dependency "license_scout", "~> 1.0"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment