Commit 883cf80a authored by Scott Hain's avatar Scott Hain

Update the required version of ruby, as ohai 14 needs ruby 2.4

Signed-off-by: default avatarScott Hain <shain@chef.io>
parent 063c55d8
sudo: false
rvm:
- 2.3.4
- 2.4.1
- 2.5
- 2.4
bundler_args: "--jobs 7 --without docs local"
branches:
only:
......
......@@ -17,7 +17,7 @@ This project is managed by the CHEF Release Engineering team. For more informati
Omnibus is designed to run with a minimal set of prerequisites. You will need the following:
- Ruby 2.3+
- Ruby 2.4+
- Bundler
## Get Started
......
......@@ -6,8 +6,8 @@ platform:
environment:
matrix:
- RUBY_VERSION: 25
- RUBY_VERSION: 24
- RUBY_VERSION: 23
clone_folder: c:\projects\omnibus
clone_depth: 1
......
......@@ -13,7 +13,7 @@ Gem::Specification.new do |gem|
gem.description = gem.summary
gem.homepage = "https://github.com/chef/omnibus"
gem.required_ruby_version = ">= 2.3"
gem.required_ruby_version = ">= 2.4"
gem.files = %w{ LICENSE README.md Rakefile Gemfile } + Dir.glob("*.gemspec") + Dir.glob("{bin,lib,resources,spec}/**/*")
gem.bindir = "bin"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment