Commit c0a66ea4 authored by Tom Duffield's avatar Tom Duffield

Avoid using git to determine gem contents

Signed-off-by: default avatarTom Duffield <tom@chef.io>
parent 3c793921
......@@ -15,7 +15,7 @@ Gem::Specification.new do |gem|
gem.required_ruby_version = ">= 2.2"
gem.files = `git ls-files`.split($/)
gem.files = %w{ LICENSE README.md Rakefile Gemfile } + Dir.glob("*.gemspec") + Dir.glob("{bin,lib,resources,spec}/**/*")
gem.bindir = "bin"
gem.executables = %w{omnibus}
gem.test_files = gem.files.grep(/^(test|spec|features)\//)
......@@ -29,13 +29,11 @@ Gem::Specification.new do |gem|
gem.add_dependency "ohai", "~> 8.0"
gem.add_dependency "ruby-progressbar", "~> 1.7"
gem.add_dependency "thor", "~> 0.18"
gem.add_dependency "license_scout", "~> 1.0"
gem.add_dependency "mixlib-versioning"
gem.add_dependency "pedump"
# from Gemfile
gem.add_dependency "license_scout", "~> 1.0"
gem.add_development_dependency "bundler"
gem.add_development_dependency "artifactory", "~> 2.0"
gem.add_development_dependency "aruba", "~> 0.5"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment